[spam][crazy][log] gdb, thread local, libgit, instruction pointet

Undiscussed Groomed for Male Slavery, One Victim of Many gmkarl at gmail.com
Sat Aug 6 21:37:50 PDT 2022

> warning: Probes-based dynamic linker interface failed.
> Reverting to original interface.

I'm guessing the above quote is related to the following then
happening. The breakpoint was not hit, so I interrupted execution to
try to quickly find the outer code executing:

(gdb) cont
Program received signal SIGINT, Interrupt.
0x00007ffff7ed54f8 in ?? ()
(gdb) n
Cannot find bounds of current function
Cannot find bounds of current function
(gdb) ni
0x00007ffff7ed54fa in ?? ()

I hit 'enter' a few times, and the instruction pointer advanced, but
debugging ended up terminating for some reason when I tried to skip to
the next ret, very strange:
0x00007ffff7ed53e6 in ?? ()
0x00007ffff7ed53e7 in ?? ()
(gdb) fini
Run till exit from #0  0x00007ffff7ed53e7 in ?? ()
free(): invalid pointer

Program received signal SIGABRT, Aborted.
0x00007ffff7a7700b in ?? ()

so i ran "run" again to try another approach to the issue. valgrind is
still chunking away.

More information about the cypherpunks mailing list