temporary fix for disabled Firefox extensions

dns1983 at riseup.net dns1983 at riseup.net
Sun May 5 07:49:12 PDT 2019


Maybe this can help you. In my case I noticed that this fix works only on Firefox android. On Firefox for Gnu-Linux it works only with Firefox ESR. You can use the same profile with Firefox ESR without reinstalling all extensions. 


This is what Giorgio Maone, the author of No script, suggests.


Il 5 maggio 2019 15:31:06 CEST, Greg Newby <gbnewby at pglaf.org> ha scritto:
>The steps mentioned below didn't help me, and the alleged automated
>fixes from Mozilla had not arrived, so I checked again and see they
>updated their documentation: 
>Turns out you need to enable Firefox "studies," which I had disabled in
>And now, the documentation says I need to wait up to 6 hours for the
>study to get loaded. These failed automated updates feel like, "give me
>convenience, or give me death." Convenience failed, and now I'm
>assaulted by ads since uBlock Origin is disabled. I had forgotten how
>unpleasant the Web is.
>  - Greg
>On Sat, May 04, 2019 at 12:51:19PM -0700, Razer wrote:
>> Steve Kinney posted this fix elsewhere. Be sure to see my addenda
>> "MOZILLA just ripped out /all/ the privacy and security tools I had
>installed in Firefox, without warning.  When I tried to reinstall them,
>FIREFOX LIED, presenting a notice indicating a broken web connection to
>the download site.  
>> How to fix this:  
>> 1)  Open a new tab, and type the address about:config
>> 2)  Ignore and click through the warning.
>> 3)  Search for xpinstall.signatures.required, and toggle the value
>from true to false
>> 4)  Search for extensions.langpacks.signatures.required and toggle
>the setting from true to false
>> Then reinstall your extensions if necessary.
>> Maybe one in 50 to 100 Firefox users would even know where to begin
>looking for a way to fix this.  Right now I am not at all happy with
>Mozilla.  To put it very mildly."
>> Addenda: 
>> "Did that, restarted browser, NoScript and and uBlock origin still
>inactive with signature warning. Went to Add-ons page. Instead of
>install buttons there were enable buttons. clicked and restarted the
>browser. Works now. Not wasting my time to see if resetting the
>about:configs to true makes the enable button at the add-on page
>disappear or not
>> Went looking for a fix last night but none were android specific and
>I didn't know the exact config terms because I'd always used an add-on
>that disabled the sig requirements in my computer's version of
>> Rr
>> Sent from my Androgyne dee-vice with K-9 Mail
>> On May 3, 2019 9:06:04 PM PDT, Mirimir <mirimir at riseup.net> wrote:
>> >| All extensions disabled due to expiration of intermediate signing
>> >cert
>> >
>> >https://bugzilla.mozilla.org/show_bug.cgi?id=1548973
>> >
>> >See https://news.ycombinator.com/item?id=19823928 for workarounds in
>> >MacOS and Linux.
>> >
>> >I posted to tor-talk, but my account may be blocked. So maybe
>> >could post if it doesn't show up soon.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/html
Size: 4135 bytes
Desc: not available
URL: <https://lists.cpunks.org/pipermail/cypherpunks/attachments/20190505/51a65f08/attachment.txt>

More information about the cypherpunks mailing list